
 

   

V15.00 

What’s new in CAEPIPE 3D+ V15.00? 
(Release date: March 27, 2026) 

 

We are pleased to release CAEPIPE 3D+ Version 15.00, delivering a comprehensive set of enhancements aimed 

at improving accuracy, expanding code compliance, and strengthening capabilities for both onshore and offshore 

piping analyses. 

Key advancements in this release include expanded wave load analysis capabilities with the addition of advanced 

wave theories and improved convergence algorithms, allowing for more precise modeling of nonlinear wave 

behavior. The introduction of combined wind and wave load cases further enhances the ability to simulate realistic 

operating conditions for offshore and partially submerged piping systems.  

 

This release includes updates to key piping codes, namely ASME B31.8 (2025), CSA Z662 (2023), and EN 13480 

(2024), ensuring continued alignment with the latest industry standards and regulatory requirements for onshore, 

offshore and pipeline systems. 

  

 

DETAILS     |    DOWNLOADS   |    LINKS 

 

https://www.sstusa.com/caepipe3d.php
https://www.sstusa.com/caepipe3d-software-download.php
https://www.sstusa.com/CAEPIPE_Links.pdf
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In buried piping analysis, cushion density can now be directly incorporated within the soil model, allowing its 

weight to be automatically included in the analysis and improving overall modeling consistency. 

 

Version 15.00 also broadens equipment evaluation capabilities with the addition of API 676 for Positive 

Displacement Pumps and HEI 2622 for Feedwater Heaters, allowing more comprehensive nozzle load 

assessments.  

 

With numerous usability improvements, extended modeling flexibility, and important bug fixes, this release 

reinforces CAEPIPE 3D+ as a robust and reliable solution for advanced piping system analysis. 
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Updated Piping Codes  

• ASME B31.8 (2025) 

• CSA Z662 (2023) 

• EN 13480 (2024) 

Refer to Piping Code Compliance section of CAEPIPE Code Compliance Manual for details on their implementation. 

New Equipment Codes 

• API 676 (Positive Displacement Pumps) 

• HEI 2622 (Closed Feedwater Heaters) 

Refer to Equipment Code Compliance section of CAEPIPE Code Compliance Manual for details on their implementation. 

New Material Library 

Material library corresponding to ASME B31.8 (2025) is added. Refer to Piping Code Compliance section of CAEPIPE Code 

Compliance Manual for details.   

Enhancements 

• Wave Load Analysis now includes three (3) additional Wave Theories namely Fenton’s Stream, Dean Dalrymple 

Stream and Solitary (Munk/McCowan) with the option for the user to input the wave order from 1 to 31 for 

Fenton’s Stream and Dean Dalrymple Stream Theories. So, starting version 15.00, for Wave Load Analysis, the 

user has the option to select any of six (6) Wave Theories, namely, Airy’s Linear, Stokes 5th Order, Cnoidal 5th 

Order, Fenton’s Stream, Dean Dalrymple Stream and Solitary (Munk/McCowan). 

• Improved convergence routine for Cnoidal Wave Theory in Wave Load Analysis. 

• New feature is added to combine 4 Wind Loads with 4 Wave Loads simultaneously in Occasional Stress 

computation, useful to analyse offshore piping, partially above water level and exposed only to wind, and the 

balance under water experiencing only wave loading. With the inclusion of these load cases, CAEPIPE now has 

the ability to define 115+ load cases and Support Load Summary for 280+ load combinations. 

• Hydrotest Stress evaluation is now added for EN 13480-3 (2024). This Hydrotest Stress evaluation can be seen 

through CAEPIPE Results Window > Results > Results… > Sorted Stresses and CAEPIPE Results Window > 

Results > Results… > Code Compliance.  

• New feature is added to use “Restrained” equations for above ground piping located between Intermediate 

Anchors for piping codes ASME B31.4, ASME B31.8, ASME B31.12 Pipeline Systems, EN 13480-3 and CSA 

Z662. This can be performed by defining PROXY soil and assigning the same to the “Restrained” piping sections. 

For further details, refer to the Section titled “Soil” in CAEPIPE Technical Reference Manual. 
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Enhancements (continued…) 

• For cohesive soil, if the soil strength specified is greater than 250 kN/m2 (0.25 Mpa or 250 psi) and the resulting 

adhesion factor is calculated to be less than 0.211, the system internally applies a minimum value of 0.211 for 

adhesion factor. 

• A new feature has been added to the Soil dialog allowing users to input Cushion Density. When provided, the 

cushion’s weight is now computed and included in the analysis. 

• New feature is added to assess piping loads applied to nozzles on Positive Displacement Pumps in accordance 

with API 676 (2022). For further details, refer to the Section titled “Pump” in CAEPIPE Technical Reference 

Manual and the Section titled “API 676” in CAEPIPE Code Compliance Manual. 

• New module added to calculate allowable nozzle loads for Nozzles connecting to Heat Exchanger as per HEI 

2622 – Feedwater Heaters (2015). This module can be accessed through CAEPIPE Main Window > New > Nozzle 

Qualification. For further details, refer to the Section titled “Nozzle Evaluation” in CAEPIPE Technical Reference 

Manual and the Section titled “HEI 2622” in CAEPIPE Code Compliance Manual. 

• “Design Pressure” and “Design Temperature” have been renamed as “Peak Pressure” and “Peak Temperature” 

respectively in Load dialog. In addition, a new feature is added to compute “Peak pressure factor” internally 

using “Peak Pressure” and “Maximum Operating Pressure” when the option “Compute peak pressure factor 

using (Ppeak/Pmax)” is turned ON through Layout Window > Options > Analysis > Pressure”. Refer to the 

Section titled “Load” in CAEPIPE Technical Reference Manual and the Sub-section titled “Pressure” in CAEPIPE 

User’s Manual for details. 

• New feature is added to reverse the portion of the stress layout. This can be performed by using the command 

Layout Window > Edit > Reverse and Paste. For further details, refer to the Section titled “Reverse and Paste” 

in CAEPIPE User’s Manual. 

• New feature is added to the Generate command. This command now supports duplicating layouts created with 

Absolute Coordinates. As part of this enhancement, the release also automatically updates the node number in 

the ‘Connected To’ fields within the Support Data types to maintain proper connectivity, if input. 

• A new feature has been added to prevent users from finding spring hangers with a specified type and replacing 

them with spring hangers without a type in the Find and Replace command. In other words, the Type field 

cannot be left blank in the ‘Find and Replace’ command. 

• A new feature has been added to prevent users from inputting Operating Temperatures, Peak Temperature and 

Reference Temperature below -460 deg. F (= -273.13 deg. C or 0 Kelvin). 

• A new feature has been added to display a warning message when the selected analysis code differs from the 

piping code for the material library selected. 
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Enhancements (continued…) 

• A new feature allows users to select the Flange Equivalent Pressure method as ASME Class 2 (2023) or EN 

13480-3 (2024), independent of the selected analysis code. This option can be accessed via Layout Window > 

Option > Analysis > Misc. 

• New feature is added to print Sorted Stresses results for  “Operating Stress for NDE” and “Operating Stress for 

Impact Test” to CSV and TXT file when the option is Turned ON. 

• New feature is added to print Minimum & Maximum Displacements results for the selected load cases when 

the Displacements results are turned ON through Print Dialog. 

• New feature is added to close the list window and change focus to Layout Window when the commands “Refine 

Nodal Mesh”, “Refine Branches” and “Reverse & Paste” are used. 

• The maximum file path length has been increased from 80 to 256 characters, allowing batch run paths to be 

up to 256 characters long. 

• A new feature has been added to create a temporary file in the Local User directory, enabling support for long 

file names in the PCF file and avoiding write access issues. 

• New feature is added in CAEPIPE 3D+ for PCF to transfer LAPJOINT-STUBEND as a Flange or Pipe by modifying 

the config_pcf.ini file. For details, refer to the Section titled “CAEPIPE 3D+ for PCF” in CAEPIPE 3D+ User’s 

Manual. 

• The following new features have been added to “CAEPIPE 3D+ for PCF” to enable smoother data transfer: 

o TAB characters and BLANK lines are now skipped during processing. 

o For CROSS components, when the BRANCH1-POINT is missing, it can be calculated using BRANCH2-

POINT and CENTRE-POINT data. 

o Similarly, for CROSS components, when the BRANCH2-POINT is missing, it can be calculated using 

BRANCH1-POINT and CENTRE-POINT data. 

o For TEE components on the run side, the END-POINT can be calculated using the other END-POINT 

and the CENTRE-POINT when one END-POINT is missing. 

• When Continuous Rendering mode is enabled via Main Frame > File > Preferences, users can temporarily switch 

between Rendered and Line views using Graphics Window > View > Render or Do Not Render. 

• Rendering of jacket piping and jacket connections (Spiders and Jacket End Caps) has been improved. 
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Enhancements (continued…) 

• New functionalities are added to the Mouse Operations as detailed below. 

o Mouse Left Button Click and Move 

1. Continuous Horizontal/Vertical PAN: When PAN mode is active, clicking and holding the left 

mouse button will allow continuous horizontal or vertical panning of the view. 

2. Continuous Horizontal/Vertical Rotation: When TURN mode is active, clicking and holding the 

left mouse button will rotate the view continuously along the horizontal or vertical axis. 

3. Zoom Window: When both PAN and TURN modes are disabled, clicking and holding the left 

mouse button will enable a zoom window function, allowing the user to zoom in/out on a 

selected area. 

o  Mouse Middle Button Click and Move (When PAN and TURN Modes are OFF) 

1.  One-time Horizontal/Vertical PAN: Clicking and moving the middle mouse button will perform 

a one-time horizontal or vertical panning of the view when PAN mode is off. 

2. One-time Horizontal/Vertical Rotation: Clicking and moving the middle mouse button will 

perform a one-time horizontal or vertical rotation of the view when TURN mode is off. 

o Mouse Middle Button Click and Move (When PAN or TURN Mode is ON) 

1. Sticky Horizontal/Vertical PAN: When either PAN or TURN mode is enabled, clicking and holding 

the middle mouse button will allow free horizontal or vertical panning of the view. This action 

remains active until the left mouse button is clicked, acting like a “sticky” operation. 

2. Sticky Horizontal/Vertical Rotation: When either PAN or TURN mode is enabled, clicking and 

holding the middle mouse button will allow free rotation of the view along the horizontal or 

vertical axis. This action remains active until the left mouse button is clicked, functioning like a 

“sticky” operation. 

• MBF format is updated to be compatible with CAEPIPE Version 15.00. See Appendix A of CAEPIPE User’s Manual 

for details. 

• CAEPIPE User’s Manual, Technical Reference Manual, Code Compliance Manual and Verification Manual have 

been enhanced and updated to be in line with the software version 15.00. These Manuals can be downloaded 

from the link www.sstusa.com/caepipe-docs.php  

  

http://www.sstusa.com/caepipe-docs.php
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Bug Fixes 

• For API 661 Qualification, the allowable column was shown as “NA” when the Nozzle Diameter is 4” (100 mm). 

• Printing the Equipment Qualification Report for API 610 to CSV and TXT file was issuing Access Violation at 

Random. 

• Sorted Stresses result is not displayed for EN 13480 when the entire layout is buried below the soil. 

• When a Relief Value Loading dialog was used more than once with a different Force Spectrum Name input, then 

it was using the Time Function data created for the first time from the back end to generate the new Force 

Spectrum data. 

• Wave Load Case is turned OFF when Mean Sea Level is input as zero. 

• Incorrect criterion value in Automatic Wave Theory selection caused Stokes Theory to be excluded for part of 

its valid regime. 

• Selecting “Dynamic Susceptibility” results was issuing “Access Violation” when the Pipe Material Density is 

input as 0.0. 

• Tensile Strength values were missing in the Material Library file B313-2024.mat. 

• When selecting a material from a library file with a version earlier than 10.60 that uses an analysis code other 

than B31.1, B31.3, B31.9, B31.12 IP, Z183, Z184 and Z662, and applying it to a model whose analysis code is 

one of the codes listed above, the Tensile Strength value was incorrectly assigned to the Yield Stress field. For 

example, when selecting a material from the library file  EN 13480-2012.mat  for a layout using the analysis 

code  ASME B31.1 (2024) , the system incorrectly mapped the Tensile Strength value to the Yield Stress value. 

  



 

   

V15.00 

CAEPIPE Code Compliance Checks 

Sl. 

No. 
Piping Code and Description 

Metallic / 

Nonmetallic 

Piping 

Above 

Ground 

Buried 

Piping 

1 ASME B31.1 (2024) – Power Piping Metallic Yes --- 

2 ASME B31.1 (1967) – Power Piping Metallic Yes --- 

3 ASME B31.1 (1973) – Power Piping Metallic Yes --- 

4 ASME B31.1 (1977) – Power Piping Metallic Yes --- 

5 ASME B31.1 (1980) – Power Piping Metallic Yes --- 

6 ASME B31.3 (2024) – Process Piping Metallic Yes --- 

7 ASME B31.4 (2022) – Pipeline Transportation Systems for Liquids and Slurries Metallic Yes Yes 

8 ASME B31.5 (2022) – Refrigeration Piping and Heat Transfer Components Metallic Yes --- 

9 ASME B31.8 (2025) – Gas Transmission and Distribution Piping Systems Metallic Yes Yes 

10 ASME B31.9 (2020) – Building Services Piping Metallic Yes --- 

11 ASME B31.12 IP (2019) – Hydrogen Piping Metallic Yes --- 

12 ASME B31.12 PL (2019) – Hydrogen Pipelines Metallic Yes Yes 

13 ASME NM.1 (2022) – Thermoplastic Piping Systems Nonmetallic Yes --- 

14 

ASME NM.2 (2022) – Glass-Fiber-Reinforced Thermosetting-Resin Piping 

Systems (GRP/FRP) 
Nonmetallic Yes --- 

15 ASME Class 2 (1980) – ASME Section III, Subsection NC – Class 2 Metallic Yes --- 

16 ASME Class 2 (1986) – ASME Section III, Subsection NC – Class 2 Metallic Yes --- 

17 ASME Class 2 (1992) – ASME Section III, Subsection NC – Class 2 Metallic Yes --- 

18 ASME Class 2 (2015) – ASME Section III, Subsection NC – Class 2 Metallic Yes --- 

19 ASME Class 2 (2017) ASME Section III, Subsection NC – Class 2 Metallic Yes --- 

20 ASME Class 2 (2021) – ASME Section III, Subsection NC – Class 2 Metallic Yes --- 

21 ASME Class 2 (2023) – ASME Section III, Subsection NC – Class 2 Metallic Yes --- 

22 ASME Class 3 (2017) – ASME Section III, Subsection ND – Class 3 Metallic Yes --- 

23 ASME Class 3 (2021) – ASME Section III, Subsection ND – Class 3 Metallic Yes --- 

24 ASME Class 3 (2023) – ASME Section III, Subsection ND – Class 3 Metallic Yes --- 

25 

ISO 14692-3 (2017) – Petroleum and Natural Gas Industries - Glass 

Reinforced Plastics (GRP/FRP) Piping 
Nonmetallic Yes Yes 
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Sl. 

No. 
Piping Code and Description 

Metallic / 

Nonmetallic 

Piping 

Above 

Ground 

Buried 

Piping 

 

26 EN 13480 (2024) - Metallic industrial piping 
Metallic Yes Yes 

27 EN 13941 (2019) - District heating pipes Metallic No Yes 

28 

BS 806 (1986) - Construction of Ferrous Piping Installations for and in 

Connection with Land Boilers (British) 
Metallic Yes --- 

29 DNV-ST-F101 – Submarine pipeline systems Metallic Yes --- 

30 

IGEM (2012) - Institution of Gas Engineers and Managers (IGEM) IGE/TD/12 

Edition 2 (UK) 
Metallic Yes --- 

31 Norwegian (1983) - Process design Metallic Yes --- 

32 Norwegian (1990) - Process design Metallic Yes --- 

33 

RCC-M (1985) - Design and Construction Rules for Mechanical Components 

of PWR Nuclear Islands (French) 
Metallic Yes --- 

34 

RCC-M (2018) - Design and Construction Rules for Mechanical Components 

of PWR Nuclear Islands (French) 
Metallic Yes --- 

35 

RCC-M (2020) - Design and Construction Rules for Mechanical Components 

of PWR Nuclear Islands (French) 
Metallic Yes --- 

36 

RCC-M (2022) - Design and Construction Rules for Mechanical Components 

of PWR Nuclear Islands (French) 
Metallic Yes --- 

37 

CODETI (2013) - CODE DE CONSTRUCTION DES TUYAUTERIES INDUSTRIELLES 

(French) 
Metallic Yes --- 

38 Stoomwezen (1989) - Dutch Power piping code Metallic Yes --- 

39 Swedish (1978) – Swedish piping code Metallic Yes --- 

40 Z183 (1990) - Oil Pipeline Systems (Canadian) Metallic Yes --- 

41 Z184 (1992) - Gas Pipeline Systems (Canadian) Metallic Yes --- 

42 Z662 (2023) - Oil & Gas Pipeline Systems (Canadian) Metallic Yes Yes 

43 

NONE (for AWWA M11 applications, and for applications in aircraft, 

aerospace & defence industries) 
Metallic Yes Yes 

 
Download an evaluation version of CAEPIPE 3D+ from the link https://www.sstusa.com/caepipe3d-software-download.php. 

  

Earlier versions' Release Notes are available at 

http://www.sstusa.com/caepipe-enhancements.php 

 

https://www.sstusa.com/caepipe3d-software-download.php
http://www.sstusa.com/caepipe-enhancements.php

